Hailo Network IP Ltd | What do I need to use Apple Pay?

Help Center

What do I need to use Apple Pay?

Last Updated: Sep 28, 2015 01:39PM BST

You will need an iPhone6 or later Apple device, and your operating system needs to be iOS8.3 or higher. Your credit or debit card also needs to support Apple Pay - contact your bank to confirm whether it does.

 

Was this answer helpful?